项目主页:http://oott123.github.com/bpcs_uploader

本地下载:oott123-bpcs_uploader-v0.1.0-beta-5-g3a75324 (1)

这个客户端需要PHP5环境,先安装php环境:

root@ip:~# apt-get install php5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libonig2 libqdbm14 php5-cli ssl-cert
Suggested packages:
  apache2-doc apache2-suexec apache2-suexec-custom php-pear openssl-blacklist
The following NEW packages will be installed:
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libonig2 libqdbm14 php5 php5-cli ssl-cert
0 upgraded, 14 newly installed, 0 to remove and 11 not upgraded.
Need to get 7083 kB of archives.
After this operation, 23.0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y

删除apache服务器

apt-get remove apache2

具体安装方法参考:http://oott123.github.io/bpcs_uploader/

系统要求

Linux (or cygwin) with php & curl installed.

使用方法

chmod +x bpcs_uploader.php
./bpcs_uploader.php

由于VPS上安装的php可能存在于各种地方,因此运行很可能不正常。请以使用which php得到你的php绝对路径,修改bpcs_uploader.php的头一句#!后的路径。 如果你的php是为了网站环境安装的,那么很有可能你会得到下面这条错误消息:

那么说明你的环境由于安全原因禁止了部分函数的执行。请看FAQs的1。请使用那条长长的命令代替./bpcs_uploader.php。eg:php -d disable_functions -d safe_mode=Off -f bpcs_uploader.php quota

快速初始化

./bpcs_uploader.php quickinit

敲下命令直接进入快速初始化流程,输入y,然后打开浏览器访问https://openapi.baidu.com/device ,在“请输入设备上显示的用户授权码:”文本框中输入上面显示的授权码(这里是12abcxyz),并点击继续。 看到网页上显示“请返回设备继续操作!”后,返回ssh上按下回车后,即完成了初始化配置。

初始化

./bpcs_uploader.php init

敲下命令之后会进入初始化流程,这里分段详述设置方法。